User Tools

Site Tools


forum:aao:ufoai

aao

UFOAI

Tasks

Two problems have to be solved to play UFO:AI on the netbook

  1. With my openSUSE 11.0 installation I get a bug inside the game. Whenever I try to start a mission the games switches to main menu instead of beginning the mission.
  2. I want to play the game in the native display resolution 1024×600

Solutions

Mission Start Bug

When I run the game from command line I got the output:

------- Loading game.so -------
LoadLibrary failed (game.so)
failed to load game library
********************
ERROR: failed to load game library
********************

Certainly you'll see the same in the log file in case you start the game via Kicker or another graphical link.

I checked some forums but this is obviously not a common bug. Finally I found an article on http://ufoai.ninex.info/forum/index.php?topic=2126.0.

It says you must copy the games.so into your local UFO properties directory, which is:

<YourHomeDir>/.ufoai/<version number - 2.2.1 in my case>/base

I didn't copy but created a symbolic link. But that's no matter.

Screen Resolution

There is a topic on the same forum used above to run UFO:AI on an EEE PC (http://ufoai.ninex.info/forum/index.php?topic=2869.0).

UFO has commandline options to set the screen resolution. They are (dedicated to 1024×600):

+set vid_mode -1 +set vid_width 1024 +set vid_height 600 +set vid_fullscreen 1

A little trap is still there. If you open the .desktop file which is used to start UFO, you'll find the run command as ufoai.sh with just a couple of options.

If you take a look into this script (it's located in /usr/bin/) you see there is no routine to forward all those options to the real program /usr/games/ufoai/ufo called by the script.

At all you have to write the additional options inside the start script instead of pass them to this script. If you do so, you are ready to go for UFO in the best solution you can have on the tiny netbook.

Conclusion

The game runs quite fast and the graphics look awesome. But sometimes for few minutes the mouse slows down and you get an update of the cursor position every 5 seconds (or so) only.

First I thought it's the general system performance because of a maybe super nice program.

But when I jump to the Main menu the system reacts as quickly as usual. So eventually it's another bug. I didn't further tests because it's randomly only…

forum/aao/ufoai.txt · Last modified: 2022/06/20 23:36 (external edit)