User Tools

Site Tools


forum:aao:opensuse-installation

aao

openSUSE installation

This topic describes the steps for installation of openSUSE 11.0

Prelaminaries

  • This install procedure will not share the system between Linpus and openSUSE. The Linpus Linux is deinstalled and all data are removed.
  • :!: Doublecheck that you have a Recovery CD from Acer as well as a backup of all your custom files
  • I've done all installation with an external USB DVD drive. Otherwise you also can create a bootable USB Stick to install a system. This forum page doesn't cover that way. But you can look
    here
    for such an installation of Ubuntu.

Rock'n Roll

Boot the CD ROM

  • Set the USB CDROM as the top boot sequence entry in the BIOS (F2 during startup)
  • Switch off the D2D Recovery
  • DON'T plug your drive in the left side USB port. The system (at least my one) can boot only from the right side ones.

Installation

  • The SUSE installation is a normal one. No need for huge explanations. I just installed KDE3. First of all so it's available when needed. Second of all the KDE4 package on the install medium are outdated.
  • I prefer not to activate the automatic configuration. So I get a first idea even during the install process what components are available and for which I need a separate module…

First Startup

  • After the installation it was not possible to boot the system. I got everytime the message Error 2 before the Grub menu would displayed. I played a little around by checking the installation and all partitions and the Grub menu.lst file with an external Linux booted from the DVD. Even renaming of the partition names in the menu.lst didn`t help. Finally I tested the Super Grub Disk (see here); quite quickly it repaired my MBR and the system could boot the first time :-D

Screen Resolution

  • Boot the system in runlevel 3 (just type a 3 in the options field of the Grub menu)
  • Edit /etc/sysconfig/displaymanager and change there the setting
    DISPLAYMANAGER_RANDR_MODE_auto="1024x600"

    Thanks,
    Linux-Magazin, GER
    for this tip.

  • Save the file and reboot the system. It should run now with correct resolution (you'll see the KDE bar at the bottom screenborder.

Update the system

  • Some of the packages here can be integrated in the system also as Community rep. This indeed is much easier. So first check the Community repositories from YaST and thereafter setup further repositories manually.
  • Activate in the menu Package → All Packages → Update, if available. Could be the entry is named slightly different. I use a German version and I'm not sure about the correct English terms.
  • Switch back to search mode and pickup all packages you want to have on your device, like KDE4 or xine or whats-o-ever. It's up to you. I got a bunch of 1,7GB to download and install. Quite enough time to write this guide ;-)

WLAN

The Card Itself

Finally it was an easy and straight forward procedure. But in the beginning I run in a trap and have a little messed up my system. What happend:

The WLAN card is one with Atheros chipset which is supported by Madwifi. Because the madwifi driver contains some proprietary part it's not included in distros. Some posts (i.e. http://www.linux-community.de/Neues/story?storyid=26172 (German)) reports you have to use a special madwifi version. You can calm down - just the actual one does also its job. There are tons of manuals how to install a madwifi driver in the net (try http://madwifi.org/wiki/UserDocs/FirstTimeHowTo). So here comes a brief overview only:

  1. Install Kernel Development with YaST (in the packages view)
  2. Download the current release from http://snapshots.madwifi.org. I use the madwifi-hal-0.10.5.6-current.tar.gz one.
  3. Extract the file and at the console go into this directory
  4. Run
    make
    su
    make install
  5. Remove the ath5k module1) with
    rmmod ath5k
  6. Blacklist the ath5k module by appending blacklist ath5k to the file /etc/modprobe.d/blacklist
  7. Fire up the module with
    modprobe ath_pci
  8. Thats it. In the Networkmanager you should be able to scan for networks on the device ath0. If there are some problems check the dmesg file.
Update 2008-09-12

:!: After a YaST Online Update I got a new kernel installed. Of course the Madwifi modules are not installed automatically. But even manual reinstalling of the Madwifi driver didn't work.

I had to take a new version (the hal version from 20080903) from snapshots.madwifi.org and:

  1. Uninstall the previous Madwifi modules by
    <madwifi-install-dir>\scripts# ./madwifi-unload
    <madwifi-install-dir>\scripts# ./find-madwifi-modules.sh -r
    <madwifi-install-dir>\scripts# cd ..
    <madwifi-install-dir>#make uninstall
  2. If you want to you also can remove the madwifi install directory. This version is no longer necessary.
  3. Install the new version as described above.

The LED

The Aspire One comes with a LED for the Wifi feature. In the Linpus Linux it indicates whether the WLAN card is turned on or off by the hardware switch.

Initially it's not working. You have to change kernel parameters to reanimate it. The commands are

sysctl -w dev.wifi0.ledpin=3
sysctl -w dev.wifi0.softled=1

For the last option you also can use the values 0 and 2. Read the madwifi article below what these options mean.

Thanks MrP (see more on http://www.skritus.de/2008/08/22/opensuse-110-kde-41-acer-aspire-one-a150l/#more-47).

Another article to get more info about the LED is http://madwifi.org/wiki/UserDocs/EnableLEDs.

The question still is where to put these commands in.

For my opinion boot.local is not the right place. My favorite was an udev rule. But it didn't worked at all for me. The

udevadm list test /class/dev/ath0

looked fine after applying a RUN rule similar as described in the Madwifi link above. But the parameters were not set in the proc folder. So I placed the following entries directly into /etc/sysctl.conf:

dev.wifi0.ledpin=3
dev.wifi0.softled=1

and this worked like a charm.

Webcam

The webcam works quite out-of-the-box. openSUSE installs the uvcvideo driver per default and the camera runs without any additional setup.

To check its function I used the luvcview program but you can use another one as well. The camera is not properly taken by Kopete which is a minor problem for me.

Suspend to RAM

The Aspire One is not a member of the S2RAM whitelist. Thus Suspend to RAM doesn't work initially.

I've tried s2ram -f and it seemed to be ok. So I created a file called config inside the /etc/pm/config.d directory and put the line

S2RAM_OPTS="-f"

into it.

The builtin features of KPowersave now works also with Suspend to RAM.

There are open issues:

  • Networkdevices are not correctly reanimated.
  • The Audio playout doesn't work after Hibernate.

Skype

Installation

The Skype install is very simple. Just download the relevant RPM file from the Skype homepage and install it with YaST.

A detailed description can you find here.

Mic

So far I didn't get the internal mic working. Even with a headset the sound quality is really poor.

Update 2008-09-13

In the meanwhile the headset was also not working whatever mixer settings I've choosen.

So I tried to update the ALSA package. For that include

http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0

as a package repository. Then update all packets - especially the alsa ones.

After a restart (no sure it's needed but I updated tons of other software as well…) I got my headset working in Skype with acceptable recording quality.

Andreas Hartmann, 27.08.2008 20:53:

UI

Of course the Window Manager, XSystem etc. are not specific elements for the Aspire One. It is one of the most subjective matter in IT design. However, here comes my solution:

On my other systems I still work with KDE 3.5.9. They are productive devices and I'm not keen enough to change them to a unknown version. They run on openSUSE 10.3 too.

On the other hand the Aspire One is just for PIM, media play, Internet and maybe to process some real files from time to time. So I decided to use KDE 4.1 and I'm really impressed.

I had tested the 4.0 several times on different machines but I was never so excited to quickly blow away my old but stylish KDE3 systems.

The Aspire One and KDE 4.1 are a great team. The system is fast enough to serve all the discreet eye candy (I hate burning or wobbling windows…) The KDE 4.1 works stable and brings enough options to create a useful and ergonomic desktop.

All my other systems have huge screens. I don't have any program icon on the desktop but in a taskbar instead. I tried this approach on the Aspire One but the screen is way too small.

So I created a desktop geared to the original Linpus Linux. Here comes a screeshot:

Screenshot Aspire One

Of course it's a hassle to switch to plasma every time you want to start a new application. Furthermore because I couldn't setup a shortcut for the Kicker menu inside the panel. But at least I could setup a shortcut for Plasma dashboard. It does nearly the same as “switch to desktop”.

Finally I'm quite happy with my solution. But I check carefully whats ongoing in terms of Netbook UIs. There are some interesting projects like Ubuntu Netbook Remix.

Open issues

Still there are some open points with minor priority:

  • I haven't tested the card readers so far. Probably I will not use them.
  • I didn't complete tests for Hibernate after upgrading to a new kernel.
1) This actually was the trap I run in. The Madwifi package serves either the ath5k as well as the ath_pci module. Just one of them can be active at a given time.

Discussion

Enter your comment. Wiki syntax is allowed:
S U W D N
 
forum/aao/opensuse-installation.txt · Last modified: 2022/06/20 23:36 (external edit)